Rendszerkövetelmények


A saját üzemeltetésű Bitrix24 verziójának rendszerkövetelményei

A Bitrix24 egy rendkívül biztonságos, kulcsrakész intranet megoldás vállalkozások számára 50-50000 főig. A hatékony együttműködés, a kommunikáció, a "social networking", a feladatok és projektek, a munkafolyamatok, az ügyfélkapcsolatok és tudásmenedzsment támogatására lett kifejlesztve. A rendszer használata növeli a munkatársak termelékenységét, motivációját, tudatosságát és egy kellemes belső együttműködést eredményez.

Minimum szoftver-követelmények

Támogatott platformok:

  • Unix, Linux, Sun/Solaris, HP-UX
  • Windows NT, Windows Server 2003/2008, Windows XP/Vista/7/8/10

Támogatott adatbázisok:

  • MySQL 5.0 és újabb verziók

Támogatott böngészők:

  • Mozilla Firefox 27.0 és újabb verziók
  • Internet Explorer 11.0 és újabb verziók
  • Google Chrome 29.0 és újabb verziók
  • Opera 18.0 és újabb verziók (Előfordulhat, hogy néhány szolgáltatás nem érhető el.)
  • Apple Safari 8.0 és újabb verziók (Előfordulhat, hogy néhány szolgáltatás nem érhető el.)

Javasolt hardver környezet

  • 2 GHz 32-bit (x86) vagy 64-bit (x64) processzor vagy gyorsabb 
  • 8 GB RAM (32-bit vagy 64-bit) vagy több
  • 500 GB elérhető tárhely (32-bit vagy 64-bit) vagy több

Részletes szoftver és hardver követelmények

PHP 5.3 és újabb verziók. Javasoljuk a legújabb, stabil PHP verzió használatát. A következő PHP kiterjesztések szükségesek:

  • GD (image handling library)
  • PHP XML (used by the update system)
  • FreeType – a CAPTCHA számára
  • Regular Expressions szupport
  • Zlib compression – a küldött/fogadott adatmennyiség csökkentésére
  • PHP accelerator

PHP-kompatibilis webszerver:

  • Apache (javasolt) 2.0 vagy újabb verzió

Database server támogatás, a következő adatbázis-motorok egyike:

  • A MySQL 5.0 és újabb verziói ajánlottak. A MySQL megfelelő működéséhez szükséges a "MySQL support for PHP" installálására. 
Memória limit:

Megjegyzés: Az egyik kritikus PHP-paraméter, amelyre a a Bitrix Intranetnek a megfelelő működés érdekében szüksége van, az a "memory_limit = 64M." Ez a minimális PHP memória, amelyet a rendszer igényel. 

Ez a paraméter megváltoztatható:

  • a php.ini fájl szerkesztésével
  • az ini_set("memory_limit", "64M") szkript meghívásával, ez telepítéskor beállítható (/bitrix/php_interface/dbconn.php)
  • a .htaccess fájlban: php_value memory_limit 64M

Adatbázis szupport

Bitrix24 és MySQL

Ez a felhasználók körében a legnépszerűbb adatbázis, mivel kielégíti az ügyfel igényeket. Biztosítja teljes funkcionalitást, lehetővé teszi a megnövelt termelékenységet, optimális működési, működtetési költségek mellett

Bármilyen PHP-vel és MySQL-vel ellátott Unix host megfelelő a futtatására.

Fontos figyelmeztetések!

Annak érdekében, hogy a Bitrix24 megfelelően működjön a szerverén, telepítenie kell a Bitrix Virtual Appliance-et (BVA), amely a Bitrix24 futtatásához szükséges szoftveralkalmazások legújabb verzióit tartalmazza. 

A Virtual Appliance elérhető Windows és Linux rendszerekhez.

A Virtual Appliance csomag a következőket tartalmazza:

  • CentOS 6.7 x86_64 operating system, automatikusan frissítve 
  • NGINX + Apache2
  • NGINX, nginx-push-stream-module támogatással összeállítva
  • PHP 5.6
  • MySQL 5 InnoDB támogatással
  • Beépített tűzfal (iptables)
  • DHCP-n keresztül megszerzett vagy manuálisan beállított IP cím 
  • Beállítható mail server agent
  • UNIX-like Control Menu alapvető parancsokkal
  • Sphinx connection varázsló
  • Kiegészítő csomagok: geoip, catdoc, poopler, man, strace
  • Könnyen konfigurálható mail client (msmtp)